Error Different country in STX and License file

I used a license file for a language that not was set up in Navision on my PC, and unfortunately I closed down the client without changing back to the proper license.(I had Imported the file). It is a local Client and DB, NAV5.0SP1.
When I try to reopen the client i get the error: Language in License file and STX file do not correspond, and the client shuts down promptly.

  • This happen regardless of what DB I am opening
  • I have reinstalled Navision-same result
  • Removing FLF or STX file do not help

Do somebody know how to reset the information about License file/STX file. It seems to be saved in some file; I have searched registry without finding anything.

PS: I have found 3 other posts on this topic, but no solution…

It’s strange that reinstall didn’t help you…

All user settings are stored in fin.zup file per user. This file is located in \Documents and Settings\username\Application Data

you need to find out what country your license is. the information is in your license number, and appear like this:
License number : US-??-???-???-? (? is whatever, letter or number). what is important is the first 2 digits.

if it’s ‘US’ , you need to find NAV US version.

may be you do not need to install it, but only extract it in separate folders. copy files in that extracted folder: fin.etx , fin.smt , fin.stx , int.stx , int.stx .
paste those files replacing the same files in your client program folder.

hope it can work.

Thank you for input.

I just found the solution: Delete fin.flf. Apparantly license information is saved there. Delete of stx file did not work.

The strange thing is that reinstall did not remove fin.flf…

Case solved.

Hi ,

I am having the same problem than you.

I am working with nav 5.0 SP1, and got the same error.

i don’t have the fin.flf file, only CRONUS.flf in the intalled directory. so i can’t solve my problem like you.

The strange thing is, that I tried to uninstall, and reinstall, and it doesn’t work.

I find a solution to work again with Navison: i have copied the all directory CSIDE CLIENT, in the same parent Microsoft Dynamics Nav,

the copied directory is CSIDE CLIENT - Copy

I can use the finsql.exe file to lauch normaly my Navision Client…

It’s strange, but it work.

have you an idea of what it is ?

Thx