Error Creating NAS in NAV 5.0 SP1

Dear Experts,

I’ve tried to create NAS in NAV v5.0 SP1 but it was not running successfully. Below are the print screen from the EventViewer. By the way, below are also some steps that I took during creating the service:

  1. Run installer and command prompt as Administrator.

  2. Added the following coding in Codeunit:1.


  1. Below are the script I use to create the service from cmd.

nassql.exe appservername=NASPIERS1, NETTYPE=TCP, servername=KELLY-PC,database=PMB_20120626, company=“PMB_LIVE”, nettype=tcp, startupparameter=NASPIERS, objectcache=40000, installasservice

!3513.NAS error.jpg|1280x800

Thanks and have a nice day!

Instead of installing it as service, use a (.bat) file for starting/ stopping the NAS Service, following is example BAT file content:

nassql.exe appservername=YourNASServerName, NETTYPE=TCP, servername=YourSQLServerName, database=“YourDBName”, company=“YourCompanyName”, nettype=tcp, startupparameter=“JOBQUEUE”, objectcache=40000,

net start YourNASServerName

For more details, please refer:

Hi Mr Dhan,

Thanks for the quick reply. May I know what is the difference of installing the NAS as a service and use the /bat file to start and stop the NAS service?

I will try it in a short while and post the outcome as soon as possible.


The “Warning” is what you need to post here.

I am not sure i see the point in using a bat-file instead of simply installing the NAS?

But i agree with babrown that we need to see the warnings from the event viewer as they will probably reveal what problem you are running into.

Hi All,

Thanks for providing your opinion on my problem. As far as I know, there is no error or warning message shown when I start the NAS service from services.msc.

Then I go the EventViewer.msc to check out the status, and that’s the only clue I have(as per shown in the print screen).

But I’m sure that the NAS is not running because it is suppose to hardcode some data into a table, but it didn’t. Any idea on how can I get the warning message or how to solve this issue?

Additional info: Windows 7 Ultimate 32 bit. NAS server and NAV Client runs on the same system, since this is for my internal testing purpose.

Hi All,

After reading the post reply again, I think what you guys mean with the warning is the event at 1:10:43PM. Here you go the print scree. But I guess this would not cause the NAS fail to work right?

Does the first warning message say the same thing as the second one?


For your information, yes. that’s the only warning message I get. Do you have any idea on this issue?

I have another question, because I’ve install NAV version 6 in my laptop, but the customization i’m working is NAV version 5. Is there any way I can test the NAS for NAV version 5 in my laptop?


I think you are using a developers license that is close to expiring. The NAS is unable to handle the message that pop up as there is no “if guiallowed” condition on this message. Thus to resolve it simply update your developers license/or get an updated version of the license.

In regard to the second question simply install a NAS (windows service) from the NAV version you are using and use that for testing.

Or do what was suggested above and simply run the NAS (in the correct version) directly using a BAT/CMD-file as shown by Dhan Raj Bansal. Simply run the bat-file from the folder containing the 5.0 NAS files.

Hi Tvis,

Thanks for your solution. I will give it a try again once I renewed the license.

Regarding the second question of running NAS version 5 in Navision 6. Because when I run a NAS(v5) in Navision 6, the event viewer will log a event that ask me to upgrade my database to version 6. Therefore, I need to get a workstation to install the Navision 5 in order for me to test the NAS(v5). Is there any other way I can run the NAS(v5) in Navision 6 environment ?

You have to use a 5.0 SP1 NAS, then you shouldn’t get this message.

I think you are getting the message because you are using a version 6.0 NAS or higher. Thus the database and the NAS do not have the same version hence the message.

But to make it easier simply use the XP mode on you Win 7 machine and install all the 5.0 SP1 stuff there. Could be easier for you?

What was your server’s Host Name and Service Name fields that you have entered.

Can you show the service screen shot from where you got the service name.