Entries change

dear experts,

I am trying to modify entry table in Dynamics NAV 2013 R2 with developers lisence and it is prompting me an error: You don’t have the following permissions TableData:Modify.

Please help :frowning:

Dear Nemirna,

Which role is assigned to your login in Navision ?


Is it a customized table or standard one ?

Standard - G/L Entry

Its the main table you are trying to modify and that too entire table ???

What’s the reason behind it.

I am aware of it…and I am trying to modify data inside of it. It was possible in earlier versions with partner lisence

What permissions provided to your login on sql server(Server roles as well as database roles).



Server role: Sysadmin

Database role: db_owner

Hi Nemirna,

I think you hit the nail on the head when you noted that you were able to make the data edits to the G/L Entry table with the partner’s license but not with yours.

I think that there was a missunderstanding, I can not edit G/L entry with partners license, that is my problem.

I know that you can’t do it with customer’s license anyway.

Ah, OK, that’s helpful too. Now, how are you trying to modify the data? Are you doing it manually by running the table object, or are you doing it through program code?

Also, take a look at whether you database has the license stored internally. Use File | Database | Alter, under the Integration tab. If the license is stored internally, then changing the license to your partner’s license in the development client won’t over-ride the license that’s running on the server.

And not to beg the question, but … getting back to the question from Manish, what kinds of data edits are you trying to make? I’m sure he’s asking because, in the accounting world, it’s typically bad form to directly modify ledger entries.

I am running the object and trying to edit field directly.

I also tied through the code, and the message is the same, only it says that I don’t have execute rights.

I noticed that also and uploaded license, but it wasn’t much of a help.

And the last but not the least…yes I am aware - and in this case I was trying to modify the date, and I know for the reverse function, but it is troubling me what is the problem since I exhausted all options to check :frowning:

Hi Nemirna,

It’s not enough to click the Upload option on the License Information window within the development client. If the license is stored within the sql database, you’ll want to alter the database to uncheck that option, and save. Then go back in, check the option, select your partner’s license file, then save that. Then, and this is key, you’ll need to restart the NAV server service. Once you’ve done all of that, you should be able to edit the data (and again, I’ll register my concern over modifying ledger data.)

George Love…thank you!