Dynamics Object Adapter call failed while opening EP Page !

In Test Server when i am trying to open EP Page it shows that " Dynamics Object Adapter call failed".Even after commenting all code in Page_Load() stil the error persists…When i am trying to recreate the page by setting->create it hangs.All other EP Pages are working fine.

But that same page is working fine on Development server.So i imported the Page Definations,Web Controls from Dev to Test.I also copied the controls and its cs file from physical path of DEV server and pasted the same in Test server.

I am unable to trace what could be the wrong ?

Can you describe the eventviewer message?

Error1## Dynamics Object Adapter Call failed. External component has thrown an exception. System.Runtime.InteropServices.SEHException at AxCore_Call(UInt32 , Char* , tagVARIANT* , Int32 , tagVARIANT* ) at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object[] paramList) at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName) at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName)## ## Error2## An unexpected error has occurred. Dynamics Object Adapter Call failed. Microsoft.Dynamics.Framework.BusinessConnector.Session.Exceptions.FatalSessionException at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsSession.HandleException(String message, Exception exception, HandleExceptionCallback callback) at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsBase.HandleExceptionInternal(String message, Exception e) at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName) at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Microsoft.Dynamics.Framework.BusinessConnector.Adapter.IAxaptaObjectAdapter.Call(String methodName) at Microsoft.Dynamics.Framework.BusinessConnector.Proxy.DataSetRun.run() at Microsoft.Dynamics.Framework.Data.Ax.DataSetRunHelper.Run(ISession session) at Microsoft.Dynamics.Framework.Data.Ax.DataSet.Run() at Microsoft.Dynamics.Framework.Portal.UI.WebControls.AxDataSource.DoRunDataSet() at Microsoft.Dynamics.Framework.Portal.UI.WebControls.AxDataSource.RunDataSet() at Microsoft.Dynamics.Framework.Portal.UI.WebControls.AxDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) at System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback) at System.Web.UI.WebControls.DataBoundControl.PerformSelect() at System.Web.UI.WebControls.BaseDataBoundControl.DataBind() at System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() at System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls() at System.Web.UI.Control.EnsureChildControls() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.WebControls.WebParts.WebPart.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) External component has thrown an exception. System.Runtime.InteropServices.SEHException at AxCore_Call(UInt32 , Char* , tagVARIANT* , Int32 , tagVARIANT* ) at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object[] paramList) at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName) at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName)

You need to check the following points:

  1. Report server service account should be running as the .NET Business Connector proxy account.(Reporting Services Configuration Manager)

  2. Ensure that the client configuration utility for Business Connector points to correct AX instance.

  3. AX instance should have the Service account specified for .NET Business Connector (Administration->Setup->Security->->System Service accounts->.NET Business Connector).

Hi Vinay

I checked all those things and everything is properly set.If you think it comes due to any of those errors then how other ep page is coming correctly !