Direct Delivery Workbench doesn't work as expected

We had a CU12 done on all our instances and after this, the Direct Delivery Workbench doesn’t seem to work as expected.

After creating a sales order on Drop ship products, the S/O would show up on the Direct Delivery workbench (MCRDROPSHIP) automatically. It doesn’t anymore.

So some things I find odd is that

while creating the S/O the direct delivery checkbox is Ticked, but when I process the sales order, and go back to verify it, the field isn’t checked anymore.

And also, in the header section of sales Order creation, in the sales Order tab, under New group, The Direct Delivery and Purchase Order buttons are disabled.

Any Ideas as to what might be going on?

It’s seems to be reacting as if on the sales order, the “Order type” is set to “Journal”. If it is set the order type to "Sales order and it should work. The default order type for new orders is in the Accounts receivable parameters - General - Sales fast tab.

Hello, thanks for your suggestion.
The Order Type is “Sales Order” under the account Receivable Parameters and I also verified this in OrderType under General Tab in the header view of the sales order form.

What process have you done? Have you tried to debug?

What is the status of the sales order lines?

When I said process, i just meant complete payments and submit.

the status of the “line status” is open order.

in the Line details of the sales order under Delivery tab, the “Direct delivery” checkbox is ticked. But after the sales Order creation is complete, when i go back in to check it again, the check box isn’t ticked anymore.
So what I tried was, modify the sales order, manually tick the check box for direct delivery and now the sales order shows up in the Workbench. But this shouldn’t be the case, it is supposed to show up automatically.

I don’t know what is making the checkbox to change after the sales order is created.

Does the same case works properly before the CU12 upgrade?

I hope you are developer. If so, have you tried to debug?

Yes, it was working before the upgrade.

I tried debugging it and the check box stays checked until the active method (SalesTable form/ salesline datasource/methods/ active) is called. It stays till the very end, until “return ret”. Once that method is done executing, the checkbox is cleared off. I am not able to tell what is being called between that end of active method to the point where the checkbox is being cleared.

What is the field name? Have a look at the cross references of that field for more information.

It is “DropShipment” in MCRSalesLineDropShipment table.

I did take a look at the references for the field and there a few places it’s used. “deleteDirectdeliveryPurchaseOrder” and “write” methods in salesline datasource of the salestable form and field method in “MCRSalesLinedropShipment” datasource >> Dropshipment field.

I couldnt find anything in these methods which would suggest the checkbox is unchecked. Maybe a second pair of eyes can help?

Does the data being inserted into that table? Have a break point in insert and update methods and see what is happening.

To Kranthi and John,

I have sent this issue over to our third party vendor and I’ll wait for them to get back to me. I have tried to debug the process and also took into account your suggestions but couldn’t figure out what’s happening.
But your suggestions were very helpful in gathering data and plausible actions where our vendor can start digging into, so thank you for that. I’ll keep this post updated with a solution as when I get it, so it can be helpful to someone else in the future.