Dimension Wizard Error for AX 2009

During the steps of configuration of FRx 6.7 for AX 2009, I ran dimension wizard.

However I got following error message and not be able to select company in configuration window.

“An error has occurred while connecting to the database.”

I did the following process, which is provided by Microsoft Knowledge base,before runing dimension wizard.

  1. Run the SQL scripts for FRx against AX database

  2. Import the Frxmetadata.xpo into AX

  • I created System DSN and it connects to DB sucessfuly

Does anyone have any idea what caused the problem?

Thank you,


I’m getting the exact same error and have been unable to solve it. Any help would be greatly appreciated!


You have the old version of the dimension wizard. This is most likely because the install didn’t complete correctly. This is very consistant behavior with the installer, so please read this carefully, as it is strange.

When you install FRx to say “C:\FRx6.7”, it installs correctly there.

When you run SP10 or SP11 to update FRx, it will find your FRx directory, and then for some reason goes one directory deeper to “Report Manager” and tries to install/update to “C:\FRx6.7\Report Manager”. Change this path to C:\FRx6.7 and the update should work correctly. Then the dimension wizard will let you choose a database, etc.