Deployment Changes not reflected without clearing usage data in AX 2012 R3 CU9

We are using AX 2012 R3 CU9.

Whenever we deploy customizations to the production server, changes are not reflected on the user’s end. Incremental & Full CIL also don’t work.

Everytime it is required to remove the usage data for all the users related to that particular form, then the changes are reflected. Due to this, the users lose their personalizations related to the form.

Is there any other alternative way to resolve this issue?

Did you try restarting AOS after deployment?

We have tried that & it is doesn’t always work. It works like 25% of the time.

And that is also not always an option. Users are working in shifts so there is no downtime available. Restarting the services every time we deploy on production will create an issue for the users. And there is no guarantee it will work.

Try to delete usage data of that particular report from SysLastValue table.And redeploy it once

That works always. But the problem is that removing the usage data even for a particular report or form removes the personalization of users related to that object. We are trying to avoid that.

Have you tried to clean client or server cache by deleting AUC aur Xppil files?

Hi,

Check the Inbound Ports in Administration Module. also Conform that initialization checklist must be completed.