Declared variable in classic report not captured in rdlc(R2) report

Hello guys,

I hope that you can help me out in my concern.

Why is it that the declared variables in classic report cannot be captured in rdlc(r2) report?

Because when I declare a variable in classic, it appears in the classic report, but when I create a layout in RDLC (Visual Studio2008) - save and close the classic, and run the report in R2, the declared variable cannot be seen?

so you want to see the variables in rdlc dataset to use them in rdlc designing,right?

add them in classic sections and set visible No…

And don’t forget to set the DataSetFieldName property of the TextBox you use to put the variable on a section.

true and just want to add that it will automatically create when you open Layout [:)]


I’ve followed your suggestions but it’s still the same.

I’ve shown up already the declared variable in dataset, I can see it in dataset in RDLC., but… when I’m dragging it to the rdlc section, save, close(classic layout) and run the report in R2, still, it did not show up.

Question: why do I have to set it to Visible = No?

If it is neccessary to show in Classic report also then no need to set Visible No… Did you also save rdlc data? Can you see the added field next time when you open layout again? if yes, there may be some other reason in showing the value…

Yes, I’ve saved the rdlc report before closing it and I can see it next time when I open the layout again. But when I preview it in R2… other default dataset in the section are visible while the added variable in global is not visible. Hope there would be other way/suggestion to solve my problem. I also tried to put it inside the table(body) and there’s no changes.

Can you show your rdlc data screenshot and report preview screenshot?

Add some BackGroundColour to newly added field in rdlc design and check…

The “About this report” should help to understand why you don’t get the value printed.

5140.screen shots.pdf (519 KB)

Please see atatched file…

The Code which is written on Section triggers is not executed in RTC so you have to move the code to GenJnlLine - OnAfterGetRecord trigger and try

1106.screenshot2.pdf (116 KB)

Thank you so much Mohanna!!