DCMEMSTREAM error

I usually use navision 4.0
then my friend used navision 4.0 and navision < 4.0 (i forgot what navision he used)
and then one day while he wanted to connect to database on the server
there was an error message that said " DCMEMSTREAM contains a record that cannot be read completely"
what’s the matter with that?
usually it worked successfully

Hi Stan,

It’s quite some time ago since you posted this question, but your post still stand as open. Have you found an answer or solved your problem?

If yes, then I would hope that you would share the solution with the rest of the user group as I think many members would get value from the answer, so that we can close the topic and mark it as Answered.

If no, then maybe you can add a bit more information to the question, so that other members maybe are able to answer your question.

Thank you.

currently i face the similar issue…wherein customer has NAV3.6 and NAV5 databases… once you try to open 3.6 database from nav 5 exe you will get a message “database must be converted before you can use it with this version of nav”

i believe the user has press OK and thus convert.ed the database…

now, when user try to open 3.6 database with 3.6 exe, he gets the message 'The File DCMEMSTREAM contains a record that cannot be read completely"

when i googled, i get some suggestions

  1. restore $ndo$dbproperty table…

  2. convert the database using new exe in single user mode

has anyone face this problem…what is the best way out