db structur error - code 1190

Hi NOlUG, we recieve an error during the Navision backup saying that we have a error in the database structur. The error occurs at table 7021 (standard license). The error message says that we have to start with parameter “DBTEST=MAX”. We tried it but during this process the db test stops with same error at the same position. Because of 63.000 records we are not able to locate the bad record (if this is the reason). We ran two reports: 1) an element from table 7021 with code: varTable7021_1 := Table7021; varTable7021_2 := Table7021; dbdelrec (varTable7021_1); dbinsrec (varTable7021_2); dbcommit; 2) an element from table 7021 with code: varTable7021_1 := Table7021; varTable7021_2.Field1 := Field1; varTable7021_2.Field2 := Field2; : varTable7021_2.Fieldx := Fieldx; dbdelrec (varTable7021_1); dbcommit dbinsrec (varTable7021_2); dbcommit; Both reports didn’t fix the error. We can’t restore our last backup. Has somebody an idea what could fix our problem? Compressing this table? Deactivate and reactive the secondary keys? Storing the recordes in a textfile and deleting table 7021? I’m happy recieving any ideas! Thanks Marc

Hi Marc, assuming this is (or was) your live database, you do have a serious problem, and this is not a time to experiment. You really should contact your NSC ASAP, and get them to fix this. I think every NSC has seen this at least once, and are trained in the correct procedures for recovery. Good luck.

Hi! The backup is back! We no more recieve the error! What did we do? - we saved all recordes of the “error”-table - deleted all records in this table - saved the table object - deleted the table object - restored the table object - deactivated all keys except of the primary key - restored the records - activated all keys We needed 2 hours for this procedure (table has 63.000 records). Marc