Date Compression / Adjust Costs error

Hi I have a problem which I see others have experienced too which is this. We have date compressed item ledger entries but when we go to run the “Adjust Cost-Item Entries” batch job an error is returned saying “Item Ledger Entry xxxx does not exist”. It would appear that this is one of the entries that has been deleted. Is this a program error? Is it necessary to run this job in the period which has been closed and compressed? If so, has anyone fixed the problem? This is in a V2.00 database. Thanks in advance. CS

I recently had a different problem with date compressed entries. Mine was in the Post Adjusted Costs routine. After some extensive investigation, I was told by Navision support that “earlier” versions of Navision had several problems with date compression. I believe V2.00 falls into the category of “earlier”. The only suggestion I have is to write a routine to thoroughly examine all the compressed data for problems. And anytime you have a problem with these batch jobs, be suspicous of the compressed records. Dave Studebaker Liberty Grove Software A Navision Services Partner

Hi Dave What do you mean by “write a routine…”. I have exactly the same problem as Craig. We run a W2.00 DB and I have tried to Date compress our DB (fortunately in our testdDB) - only the Item Ledger Entries. When I run the Adjust Cost report, I have the same problems as Craig. Does anyone knows how to correctt this? Our Item Ledger Entries table is now > 3,5 GB and growing. This means a slower DB when working with Items. Best Regards Mads Morre DK

Hi Craig, We had a simular problem a few years ago which was corrected in Service Pack2 for 2.01. This is from the documentation. Error: The Date Compress Item Ledger batch job’s check for full adjustment of cost price did not provide enough security. After you ran this batch job, you sometimes got an error message the next time the Adjust Cost Item Entries batch job was run. The error message stated that a specific item ledger entry number did not exist. Error Location: Item Application Entry table (339) Date Compress Item Ledger report (798) This has been corrected. Correction: The new key in the Item Application Entry table is by default “not active” because the majority of customers do not use date compression. If customers use the Date Compress Item Ledger batch job, it is recommended to make the key active. I beleive we corrected this problem by manually ticking the “cost is adjusted” field on the Item Ledger Entry and Manually posting any assocaited entries, then upgrading to Service Pack2. Hope this is of some help. Sean Brady