Datasource displays in AOT but not available when adding Query to Dataset

( Test>usr environment for both DynamicsAX 2012 and Visual Studio 2010)
After Creating a Query and saving (with no errors) to AOT, I then go to Visual Studio to
create my report.

-I creat a new project,

  • then create a new report ,
    -then I Create a Report Dataset
    -After I create my Report node I right click to Add Dataset
  • In the properties window, I specify all the values as needed
    -when I go to Select my query, it does not show up
    yet the Application Explorer shows it-

Is there a setting we should be looking at ?
I should menton that it worked fine in Production but I do not know whatto look at.

Hi Jim ,

Firstly after you create your dataset node , then create a new dataset with the properties window …

datasource - Dynamics Ax

Datasourcetype - Query

Default layout - Table

Dynamics Filters - True

Name - ********* name of dataset ()

Query - then clicking on the small window at last will give you all the qureies from AX . Select the query and it should be fine .

i hope if you have same properties on ur dataset , it should work for Query .

Nisha…

Hi Nisha, Thank you for the response-

Ths is a test environment, when I did this in production it works fine, but management has told us to work in test for developement. So I have directed both my Dynamics AX and Visual Studio to the Test environment configuration. Perhaps I did not make myself very clear. The query shows in the AOT (test) however when I click on the drop down box to select query(small window) the quesry in AOT does NOT show up in that small box . please see screen shot below. My query is named QueryJt1(usr). It should be noted that only production queries are listed.

Thank you once again- Jim T

Hi, a question because the parameters that will be fixed on a Query from AOT, as ranges, Groups are not respected when we display the query in a table of a report?

Can you try this:

Go to the AOT right click on the query node or class (that is the source for the report) and select restore and/or on the VS SSRS project right click on the Data Set and choose refresh.

Bijan

Hi Jim,

Just wondering if you ever got the solution for this problem that you posted. Please let me know if you got one.

The problem in this case is because the Dynamics AX configuration has been properly set.

  1. Go to “Microsoft Dynamics AX 2012 Configuration Utility”.

  2. Go to connection tab and check if it is pointing to correct AOS instance.

  3. If not, then click on “Manage” button, then “Import configuration from file”.

  4. Select the correct configuration file and click “open”.

  5. Click on “Refresh” button

  6. Click “OK” button

You should now have correct configuration imported and should show the query or report data provider in the dataset.

I’m having this same problem, my query is shown in the “queries” node of the Application Explorer, but doesn’t appear in the list of queries I can select when I add a dataset to a report.

I can’t figure it out, the report dataset query list actually seems to be coming from one of our other AX instances.

See comment by ADAM260 for the solution.

https://community.dynamics.com/ax/f/33/p/107669/224909.aspx

I tried it and it works.