Dataport do not fill the table

Hi everybody,

I have prepared a dataport to introduce many information to the table Contact Profile Answer (5089) on the Navision 2009 SP1, the dataport includes the following fields:

“Contact No.” - “Profile Questionnaire Code” - “Line No.” - “Contact Company No.” - “Last Date Updated”

The problem is that when I run the dataport, i runs correctly, but when I go to the table no data is inserted… I have changed the 3 properties AutoSave, AutoUpdate and AutoReplace to different values, and nothing happens. Also I have tried to put more fields in the dataport (like the value, the company and contact names, the answer)…but I obtain the same results.

Can anybody help me in how to make this?

The format of the text file to import, is correct, because I have made many other dataports, and never I have had this issue.

thank you in advance!!!

Where do you execute your dataport from? If you open it in design-mode and run it from there, the dataport will run, but it does not insert anything. If you run it from object-designer-window or via a menu, it should work. If all definitions are correct, that is…

Dear Affinur,

thank you very much for your reply…YES, that’s the problem that I have. Two months ago we updated from Navision 2.65 to Navision 2009, and I think that before this issue does not exist, so you can run the dataports from the designer without limitation…or at least maybe I didn’t does this before.

I’m a little bit embarrased about this stupid problem…but you have solved something that it’s running me crazy.

Thanks again!

Or a COMMIT in the OnPostDataport trigger will also do the trick.