Database (native) not able to open

One of our client is having a problem while opening the Navision Native Database (Nav 4.0 SP3). The database size was 8gb. While opening , they are getting an error to expand the database. They have expanded the database size to 12gb and still the same error was showing. We have copied the native database into a new folder and trying to open on normal client mode. Still the same problem was occurring. When they are working, there was a power break down. All the machines are went off. After power came back, when the users to try to open the database for updations, they are getting the error. We can able to open the database but couldn’t operated anything.

Would it be possible to post the error message here ?

Do you face the problem from each machine or have you successfully opened the database at least from one machine?

3582.Doc33.doc (103 KB)

Any chance to get solution for my above issue.

I had experience with such problem few years ago.

  1. go to database test and find out table that has error.

  2. if table is not important - delete all records using deleteall(false)

  3. if table important you will have to find record that is corrupted… Create report with all fields and in OnAfterGet record save primary key to a file… At some point you will get error and report will close. - Open file and you will see last non corrupted entry… Using code delete entry without reading it - just fill in primary key and “delete”. Repeat it as many time as nessasary - in my case it was about 4 recors.

When you fix it - buy UPS.

This is a critical error, had it myself last year in a 30 GB base. Only secure solution is to get a backup and restore it; and make the restore into a new FDB-file, not the old one.
If your only backup-copy is a FDB-file, copy it and run a test (normal og maximum) on it.

If you don’t have a backup, you may have kind of a problem. But try to open database as single-user with parameter “dbReadOnly”. Then make backup (via Tools → Backup); try company by company and then “Data common…” and “Application Objects”.
This may work if the error is in an index only. If it doesn’t work, do as Valentin writes and then try again.

Good luck!

Dear Sir

One of other client who was using Navision 5.0 SP1, when they try to open the database, there was a message showing as Recoverring blocks and it is trying to recover upto 31% and then showing an error. The client couldn’t use the database.Do you have any suggesstion or tools or any other way to open the database. Your recommendation will be very very helpful .

The following is the error mesage,

Microsoft Dynamics NAV

There is an error in the database structure. The error (1084 in module 19) may have been caused by the computer or a program.

Key Fields:

First check the database by clicking File, Database, Test and then click Maximum. If you still get the same error, you should:

  1. Make a backup of the database by copying the database file(s).

  2. Use the built-in function to make a backup.

  3. If this works, create a new database WITHOUT deleting the database that contains the error(s).
    Restore the backup (made with the built-in backup function) into the new database, and test it by clicking File, Database, Test and then click Maximum.

If this procedure does not work, any changes to the database done after the most recent backup are lost. Restore the most recent backup (made with the built-in backup function) and test it.
For security reasons, you should save the old database until you have used the new one for a period of time.

Warning! This error MUST be corrected before you can continue. Contact your system manager if you need assistance.---------------------------