Data Migration stopped working

We just upgraded to Nav 2009 R2. since then the data migration tool has stopped working.

I import the same file into our old database and it works fine so I think the file is OK.

I get the following error

The call to member selectSingleNodeFailed.msxm.dll returned the following message

Expression must evaluate to a node-set.

More info please!

When running in old database do you use new run time exe files?

Do you use XML port or homebuilt Codeunit? (I presume it is an xml file based on the error message and thus do not consider Dataport to be an option)

Basically in the xml standard an xml file must have only one top Element in one file.


I am using form 8614. The file is an Excel spreadsheet. On the form I have a choice of importing from xml or xls. I am choosing xls

Had that same error a few months back but can’t remember how the programer solved it :frowning: Was it the automation Server in Excel…Can’t remember.

You might want to check this, pretty simliar to your error message: