Customer Report Selections Page 9657 Will not display additional options

We would like to add an addition option to the list of Usages available on the Customer Report Selections Page: Packing List. We see the logic relating the OptionString values for the Usage2 field on this page to the OptionString values for Usage in Table 9657-Custom Report Selection. But when we add “PackingList” to the OptionCaption property of the page, it will compile and run but not display the new option in the dropdown on the page. In addition, we can manipulate the option values in the table Custom Report Selection so that numerically the code behind the page would point to the position of the new option–but then it displays a blank in that field.

Is there something unique about this page that limits it to work with only the 6 options that it contains out of the box?



You need to code the new usage options both on the report and on the page using it.

Hi Erik,

Thanks for the response. I’m not sure I quite understand–I am indeed trying to add the new option to the Customer Report Selections list page. That much is done. But it will not display. As for adding the new usage option to the report, I don’t know how or where I would do that. The “page using it”–would that be the Sales Order Shipment card where the Packing List action lives? Again, I don’t see where I would do that. Maybe I am not looking at this right, but this all seems to be related just to the “Usage” pattern between Custom Report Selections table and Customer Report Selections page. Should I even be trying to add options to the latter? Is that allowed?


Found it. I had only been changing the OptionCaption string, which is what you get when you show the Properties from the page designer. A colleague pointed out that I had to go to the actual global variable, and change the OptionString there. Once I got that right, everything else worked out. Table 9657, Custom Report Selections, was missing a caption for one of the OptionString options, but we were able to fix that too.

Thanks again!