CRM and AX Integration Test Setting Error.

Test settings failed:

The following exception occured while attempting to retrieve endpoints:

System.Net.WebException:The request failed with HTTP status 404:not found

A connection to the Microsoft Dynamics AX AIF Service could not be validated using the “”>tblax:8070/…/"URL.

The Event Log Message:

WebHost failed to process a request.

Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/59594809

Exception: System.Web.HttpException (0x80004005): The service ‘/MicrosoftDynamicsAXAif50/localendpointservice.svc’ does not exist. —> System.ServiceModel.EndpointNotFoundException: The service ‘/MicrosoftDynamicsAXAif50/localendpointservice.svc’ does not exist.

at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.HandleRequest()

at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.BeginRequest()

at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)

at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)

Process Name: w3wp

Process ID: 3576

Give a solution

Thanks in advance

Following this guide: msdn.microsoft.com/…/cc652581.aspx

You need to…
Go into AX > Basic Area > Setup > Application Integration Framework > Web Sites… and add a site with the path to your web service directory
Go into AX > Basic Area > Setup > Application Integration Framework > Services… Click Refresh… check LocalEndpointService… click generate
Open your web service directory and modify the web.config…

Remove httpModules section
Add a new bingind to <system.serviceModel>… “”
Update the binding and bindingConfig for each service behavior to wsHttpBinding and wsHttpWindowsAuthAif