Copying a Splitted Database

Hello. I have the necessity to move my NF 2.01 database from one server A to another server B. Actually, My database is splitted in two files and resides into drive D: , the new location is under drive C: , so when the client connect to the new server B receives the message ‘can’t find file D:\database2.fdb’ . Does Anyone know how to change the path of the second (third, etc…) file of the database??? Thanks in advance.

  1. make a backup of your current database 2. create a new database in the new location, splitting it into as many parts you need 3. import the backup Lars Strøm Valsted ------------------------- Why can’t programmers tell the difference between Christmas and Halloween? Because OCT(31) = DEC(25)

On second thoughts… I think you can just copy the files, then delete the dbms.zup file then start the client program as single-user, and select the first database part. After that I think I remember something about the program asking me for the subsequent database parts. Lars Strøm Valsted ------------------------- Why can’t programmers tell the difference between Christmas and Halloween? Because OCT(31) = DEC(25)

Many thanks for the answer! I’m going to try your hints on my hated server. I’ll report the results very soon. Bye!

Hi Lars, the second way doesn’t work. it seems that NF mantains the information of the database files (except for the first, that can be choosen by the user or by the server) into the database itself and not in the dbms.zup file. Moreover, it seems there’s no easy way to modify the path choosen at the time of the split, even searching through tables. So, i’m going to try your first hint. Bye!

Second way has always worked for me, I just do a LOCAL file open of the database, like this : File\Open THEN : G:\Navfdb\nav1.fdb+nav2.fdb+nav3.fdb+nav4.fdb+nav5.fdb ###### tarek_demiati@ureach.com

Hi Tarek, thank you for your help, but i still got a problem when i try to open the database in the way you explain. Windows 2000 tells me that the file can’t be found! I tried with the following paths: c:\database.fdb+database2.fdb c:\database.fdb+C:\database2.fdb i tried to open with shell command, too: fin.exe database=C:\database.fdb+databse2.fdb But there’s nothing to do!!! I’m going crazy about this… Any further help, please? Thanks.

Hi! In order to this matter, is it possible to change the path directly in a system table?? Is it possible in some way to open the system tables?

There are 2 things you might want to check with the shell command. 1) You have to run the fin.exe from the server. It is the only one with the correct path (c-drive). 2) For the database parameter, each file needs a full extension. Usually I find the easiest is to go to a dos prompt, change the directory to the database directory and then specify the directory for the fin.exe Try something like: C:\Program Files\Navision Attain\FIN.EXE database=C:database.fdb+c:database2.fdb Hope this helps.

Thanks to you all! Both ways work. The only trouble i had was dued to the extreme complexity of the database path. when i migrated my files from C:\Documents and Settings\dev2000.CRIPTA\Desktop\Navision\database.fdb to a simple: C:\Db\ the procedure finally worked! So, in this case an extremely complex path can cause troubles. Thanks again. Bye.

Domenico is correct. There is a path name text length limitation in this case that can be extremely frustrating. So when you use Lars’ and Tarek’s method of copying the database files, you will have to make sure that the total path name is short. I don’t remember the exact length limitation. I think that you can use Environment Variables to define “synonyms” or “aliases” or “Symbolic Names” that will equate a short name (e.g. DB1) to a long path name (e.g. C:\firstdirectory\secondsubdirection\thisisgettingwaytoolong\databasepartone.fdb). Dave Studebaker das@libertyforever.com Liberty Grove Software A Navision Services Partner