Client gets no Connection to AOS?

Hi,

I just installed an AX test environment as my company is going to use Axapta in the future. Currently, I am having trouble with connecting a client on a Windows 7 machine to my AOS.

Everytime I start the AX client on the Windows 7 machine, it immediately says “Connection to the Application Object Server could not be established”. The strange thing about it is, that if I open the client installed on the AOS itself, it works fine. The client on the windows 7 machine and on the AOS are sharing the same configuration.
Additionally, I turned of windows firewalls on both machines to ensure that there is no problem with firewall settings.

I was also able to ensure that the windows 7 machine is really talking to the AOS before throwing the error message, so I really dont know whats the problem here…

I’m an AX-newbie, so maybe there’s a simple explanation for this… [:)]

Verify your client configuration is correct in Control Panel>Administrative Tools>Microsoft Dynamics AX 2009 Configuration

I’m guessing you aren’t really sharing the same AOS configuration. AND/OR the AX configuration you are sharing uses something like “localhost” instead of the machine name. So when you use it from another machine, it tries to connect to itself.

Alex,

the client configuration is correct, I just re-checked it. I am startign the AX client with the command

“C:\Program Files (x86)\Microsoft Dynamics AX\50\Client\Bin\Ax32.exe” \axfiles\axconfigs\client-axlab-prod.axc

which should load the configuration from \axfiles\axconfigs\client-axlab-prod.axc - is this correct?
Additionally, as mentioned before, I was able to ensure that the client is really talking to the AOS over the network before throwing the error message. From what I could see in the TCP-Dump, the AOS says somewhat like “Access denied” to the client.

Is there a need to define Subnet/IP-ranges from which clients are able to connect to the AOS? My client is in a different subnet as the AOS is.

I think your syntax is wrong just slightly. You should put single quotes around your AXC network path and it should all be inside double quotes. This will probably fix your issue. Currently, you are just running whatever your default client configuration is. Another test you can do is just double click on the “client-axlab-prod.axc” file and when it asks what to run with, navigate to the Ax32.exe client (You may have to navigate to this file twice).

“C:\Program Files (x86)\Microsoft Dynamics AX\50\Client\Bin\Ax32.exe ‘**\axfiles\axconfigs\client-axlab-prod.axc’**”

That’s also not working, same effect: No connection to AOS. slowly but surely, this is driving me crazy…

Hi,

I have connected to AOS from Windows 7 OS before so I know it works. Just a few thoughts -

  1. From the client machine, are you able to browse this location '**\axfiles\axconfigs\client-axlab-prod.axc’** with Windows Explorer? Also are you able to create a text file without any error?

  2. Instead of using server name, have you tried using IP address? Does this make any difference?

Hi,

yes, I tried both things, but it had no effect at all…

In the meanwhile I have another problem, which I think has the same cause: I tried to install the Business Connector and it failed while connecting to the AOS. It says I should check if DOMAIN/Administrator is a valid AX user. But DOMAIN/Administrator IS a valid AX user as I can run the client on the AOS itself as DOMAIN\Administrator without any problems.

Michael S.,

It really sounds like you have a firewall issue on the AOS itself, or the default port has been changed. Try connecting to it via a different client machine.

On the AOS, verify the port has not been changed. To do this, from the AOS, go to Administrative Tools>Microsoft Dynamics AX Server Configuration Utility. From the drop down at the top, make sure the AOS you are trying to connect to is selected, and the port should be displayed below (2712 default).

I’m not convinced your client configuration is not screwed up. On the workstation that you are trying to connect with, let’s rule out the client configuration. Go to Start>Control Panel>Administrative Tools>Microsoft Dynamics AX Configuration Utility.

  1. Click Manage>Create New Configuration, name it “TestConfig” and select it as the active configuration.
  2. Make sure your configuration target at the top says “Local client”
  3. General tab should be mostly blank
  4. On the connection tab, click whatever is there and click delete.
  5. Click Add, and then type the server IP address, leave the instance name blank, and put 2712 (or whatever the IP is)
  6. Click OK, OK, to close out the configuration utility.
  7. Go to Start>Programs>Microsoft Dynamics AX 2009>Microsoft Dynamics AX 2009.

If this does not work, it’s almost guaranteed to be a firewall issue. Also, verify the error you are getting is “Cannot establish connection to the AOS” and not “You are not a recognized user” or something else.

Finally, the cause of the problem was something completely different [:)]
It figured out, that an error occured while sysprepping the virtual machine template from which I deployed all my lab machines. Because of this error, all the machines, including the domain controller, had the same SID.

Every time I tried to connect to the AOS, there was an windows event on the AOS, saying somethig like “the domain-SID is inconsistent”.
Re-SysPrepping alls my machines but the domain controller solved the issue.

But anyway, thank you for your ideas!!!