Can't restore DB from backup

Hello! Since I use Russian version of Navision texts of some messages mentioned in this topic may differ from those appearing in situations I describe. But I’ll do my best to make meaning of the messages clear for you. In fact the DB is restored only partially. Every time I click the OK button on the “Restoration process completed successfully” messagebox I find the same picture in the Object Designer - nothing is restored except table. I.e. no codeunits, no forms, no reports. After choosing backup file I get the Restore dialog with the Common data for all firms and Application objects checkboxes inactive. But when I made the backup I checked those boxes. Thanks in advance.

Hi You need to create a brand new database, when you restore it into this you will see the tick boxes are active on the objects.

Hi yegor You have restored a database from a backup that did not include the application objects. A full backup must have the ‘Application objects’ tick box checked.

Yegor IF you still have your source system and db, I have an easy method (I like simple stuff). On the old system 1 - make sure everyone is OFF Navision 2 - STOP the Navision service. 3 - COPY the Navision db file database.fdb 4 - START the Navision service On your new system (2 options) a - a NEW install 5a - copy the copied file from step 3 above to the new server 6a - when you install the new system, point it to the file you copied. b - an existing installation 5b - STOP the Navison service 6b- copy the file from step 3 above, and replace the Navision db file 7b - START the Navison service This process works fine. I used it several times to create test systems and to move systems from one server to another. This is also my disaster recovery process, so I KNOW my DR process works. In fact for a couple weeks I used the “b” option to create a “ready backup” of my PRODUCTION system. The ready backup always had the db from the production system as of the prior midnight, so it was no more than 1 day behind, or as current as my backup tapes. If my production system “died”, I would simply turn the ready backup ON. Admitedly, not eveyone will have a spare server available. However, the same process can be used to change the test system into the recovery system. Now the only thing I do NOT like about this process, is I don’t get a db check that I do if I run “hotcopy”. So…I also run HotCopy, to do the db check, and at the end I have 2 backups each night…belt and suspenders. gud luk Gary

I am having the same problem as yegor (We are using Navigator 4.3 NA 4.0 (4.0 sp3) with SQL Server 2005 ) . We can’t use Gary’s solution as all our Navision databases are on the same server. I created the backup in Navision with the Data Common to All Companies and Application Objects options checked. There is another person who creates backups, following the same procedure, and she always checks those options as well. Just to be sure, I tried to restore older backups, and all of them come up with those options grayed out. We last restored a backup in September with no problem, so I tried to restore that backup and still the options were grayed out. We are on MS Server 2003 Standard Edition, SP2. Our server administrator keeps us current with OS updates, so I am wondering if a recent patch might have caused this. If anyone else has encountered and solved this problem, please share.


Although some posts above Adam already gave the answer, you all keep on asking again :slight_smile:

Once more - to restore Objects, you must have a new (clean, empty - as you call it) database to restore into.

If there are already Objects in the DB, corresponding checboxes will be grayed out, doesn’t matter contains your backup Objects or not.