Can't connect to 2. instance of Financials server

Hi guys,

I have a very strange problem at one of my clients’.

They have 2 instances of Financials server installed on their server.

  1. instance is a 2.60 B server (running on port # 2407).
  2. instance is a 2.01 B server (running on port # 2408).

They have several workstations, and all run Win Xp.
At just one of them, i can’t connect to the 2. instance (2.01 B).
All other workstations connect without any problems.

I keep getting an error, that the server and client isn’t same version, wich indicates to me, that when i try to connect to 2. instance it somehow keeps trying to connect to the default port (2407), even though i’ve modified the services file according to ISM-manual.
I’ve tried to copy the services file from one of the other workstations, still same result.
I’ve double-checked that the client is the same build as those that connect fine.
I’ve checked that the TCP-properties are similar to those that connect.

Anyone have any ideas to what could cause this behavior?

Did you tried to use servername:port instead of using service file?

Yes, i tried to do both servername:port and serverip:port…

No luck.
I gave me an error, that the host could not be solved, and i needed to modify the hosts-file.
But this same error came on one of the other workstations, that can connect, so i concluded that that syntax wasn’t valid with 2.01
(Even though i seem to remember doing it like that some years ago, but i might have been on a 2.50)

did you moved ZUP file to another folder and tried to connect to server? Just trying to give some hints…

I really appriciate that you take your time to try and help me.
Please keep anything that comes into your mind coming.

I did try to both renaming, moving and deleting the zup-file.
I also have tried to reinstall Navision, just in case something went wrong in the installation.
I’ve even tried to reboot the workstation several times. - LOL -

No luck…

Maybe it can be a good idea to (technically) upgrade the 2.01 to 2.60 or both to 4.00SP3. It gives new technical possibilities and you don’t need to control 2 different client-versions with the possibility that you (or someone else) opens 2.01 with 2.60 and converts the DB.

Hi Alain,

I totally agree with you on this.
They are actually in the process of a proper update, so i’m just “keeping them alive” until that has been done.

However i’m not sure it would solve my problem…

Having 2 instances of the same version of Navision databaseserver, would still call for the client to connect to 2 different ports.
And my problem here is that somehow one of the workstations, won’t connect to other than the default port.
The 2 databases each have a lot of modifications, that can’t just be merged. So I can’t put all companies into the same database.

Since these a very old versions. Did you tried to change server ports between 2 servers? It seems that version 2.01 can’t connect to server besides it’s default port. I can’t confirm that.

You still have 2 databases, but both should be able to use ports. Or like nuno said, try to invert the ports.

Yes, i might try that.

But i still find it strange, that they have about 15 other workstations, that connect to the Financials 2.01 server, on port 2408, without any problems.

I’m thinking that this has to be caused from some setting i windows, or something else on the particular workstation, rather than an actual Financials issue.
So i expect that inverting the ports, would cause the 2.60 client to get problems connecting.

Hi again,


Inverting the ports didn’t solve my problem.