Cannot Start Financial Server

We are having problems with our existing Navision Financial Server Which is NT4, so we have installed Navision Financial Server on a Windows 2000 server. When we try to start the server we get the following error message: “Could not start Financial Server NAVSERVER service on Local Computer” Error 1: Incorrect Function We have also tried to run server.exe from the CMD line, and we get the following error: “The Operating System returned error (87)” The parameter is incorrect. Is there something special to start services on Windows 2000 we are using v2.50. On the install, it did not start the service either. It gave us a message to tell us to configure it manually. How do you configure it manually, I have read the documemtation, checked the registry setting, and everything seems to be set.

Since it sounds like you just installed this server, I’d delete the dbms.zup file found in the server installation directory. THis file acts just like a normal zup file, holding information about the server startup. Then, I’d start the server from the command line with no parameters and make sure that works. Then I’d keep adding one parameter at a time to the command line until it either works or errors out - at least that way you’ll have more information. And if I had to guess - I’d wager it’d be the Cache setting - Navision loves to eat memory - and if you have other apps on this server, Navision may be trying to take more memory then is available.

Question: Did you change the cache setting while installing the Navision Server? I’ve seen this error once and that was when a colleague didn’t change the default cache setting. Because the server had a lot of RAM, Navision set the cache size to 1000000 kb. This is a bug in Navision because the server can only use less than 1000000 kb in 3.60 (I don’t know the max setting for 2.50 however!)

This message is sometimes received if your database path or file names are long. Try again with shorter ones.

quote:


Originally posted by Sheina “The Operating System returned error (87)” The parameter is incorrect. Is there something special to start services on Windows 2000 we are using v2.50. On the install, it did not start the service either. It gave us a message to tell us to configure it manually. How do you configure it manually, I have read the documemtation, checked the registry setting, and everything seems to be set.


If the database is on a network folder, remember also to map that folder and refer to the database using that mapping as it was on a local drive (example: if the database is in \databaseServer\navision\database.fdb , map \databaseServer\Navision as drive X: and then refer to the database as X:\database.fdb). For configuring manually the server you just need to open a shell window and go to the folder where you’re having the server installed. On that folder you’ll find the executable (SERVER.EXE) that’s allowing you to use different parameters (SERVER /? will give you a list). You can use it for removing/adding the service on NT also by using the INSTALLASSERVICE and UNINSTALLASSERVICE parameters. When running it manually you can also choose the database name with the parameter DATABASENAME=fullpathtothedatabase\databasename.fdb All parameters are separated by comma. For a normal standalone installation you’ll just need something like: SERVER DATABASENAME=Fullpathtothedatabase\databasename.fdb,NETTYPE=TCPIP,INSTALLASSERVICE and then go to windows nt4 services and start the service. Regards,