Cannot edit a record in Uncommitted sales tax (TaxUncommitted).

Hi everyone,

When our procurement team recalling the PO and updating it with the sales tax and submitting it for PO approval again, then system creating DB lock in the SQL database server and our workflow engine getting stucked. I have to kill the DB session from the DB server to run the workflow batch job but the PO workflow status showing following below error with status as “Stopped”:

Cannot edit a record in Uncommitted sales tax (TaxUncommitted).

Stopped (error): X++ Exception: Cannot edit a record in Uncommitted sales tax (TaxUncommitted). Date: 3/7/2018.
The SQL database has issued an error.
at SysWorkflowWorkItem-create

To me this seems something weird behaviour of the system. Its happening only when we are doing request change to the PO and then submitting it again after adding sales tax percentage to the newly added item line.

Kindly help.

Are there any customization’s in that area? You may need a developer to debug and investigate the issue.
Also check in LCS if there are any bugs related to it.

Hi Kranthi,
Thanks for the quick response. There is no customization on it. Strange thing is its working fine in TEST environment and we cannot debug on LIVE. I tried to compare the difference between two enviornments but failed.

So the TEST data and LIVE data are same?
Is this only happening for a single PO or all the PO’s (with same scenario)?

Hi Kranthi,
data is not same, its quite old and its happening to all POs which are getting revised specifically for adding Tax groups and amount.

If it is happening with all the PO’s then there could be a bug in the code.
Have you tried moving your LIVE data to TEST ? If you can reproduce this issue in TEST, you may have the developer to debug in TEST.

Yeah seems thats only the solution to move DB from LIVE to TEST and debug.
Thanks Kranthi

I am marking this thread as answered, let us know if you have any further questions.