Cannot connect to SQL Server


I planned to install AX 2012 r3 with CU10 slipstream install.

  1. Installed Database in Database Server

  2. When I try to install Database for AX from Applicaiton Server…it says " Setup could not connect to the databbase sever "

Already tried solution:

In DB server : I enabled Tcp/ip and Named pipes + User already added - Gave all privileges + Firewall disabled on both servers

  1. I can ping from servers using servername (from db to appln server and vice versa)

If any one has solution other than what I tried…Kindly reply.



Please tell us what version of SQL Server you’re using and whether you’re able to connect to the database server with other tools, such as SQL Server Management Studio (from the same machine where you’re running AX installer).

At one client site.: 2 Servers [for DB and Application]

Domain: ******

User logged in DB aswell Application server : axadmin

DB server: Windows Server 2012 R2 Standard

Sql Server: SQL Server 2012 SP1 + Later updated SP3 over it

· Version: 11.0.6020.0

RAM: 16 GB

Application Server: Windows Server 2012 Standard


I want to install AX 2012 r3 with CU10 [SlipStream Installation]


I want to install AX Database thru Ax setup. But its not displaying the Database Server name in the list .

· I typed the db server name “DB-SRV” then error says : Setup could not connect to the Database Server ‘DB-SRV’

In dynamics user forume, only guy asked can u able to connect thru Sql Server Managmenet studio from the server you are running the ax installer. SO

· Installed Sql Server Managmenet Studio in Applincation Server, and try to connect to the Dbase Server…thru option “Select from Network Servers”

o I selected the Server name and pressed CONNECT…but error came :

§ cannot connect to DB-SRV

§ Under Additional information: The target principle name is incorrect. Cannot generate SSPI context (Microsoft Sql Server)

Solution tried :

In Database server :

  1. Checked axadmin user has all privileges. I selected all privileges under DB-> Security->Logins=ALMANAR\axadmin user == for server roles

  2. From Sql Server configuration manager

a. Enabled TCP/IP and Named Pipes for Client protocols under SQL Native Client 11.0 config(32bit) and also

b. Enabled TCP/IP and Named Pipes for Protocols for MS Sqlserver under Sql Server Network configurtation and also

c. Enabled TCP/IP and Named Pipes for Client protocols for Sql Native Client 11.0 configuration.

Network and my concern

· No servers has got IP address. Its DHPC

· But, I can ping to each others by name – Fine.

If you can’t connect to the database server with SQL Server Management Studio, it’s clear that your problem isn’t related to Dynamics AX. You. have a problem with SQL Server.

Look at previous discussion about this error (such us MSDN SQL Server Security forum: The target principal name is incorrect and StackOverflow: Cannot create SSPI context) and if necessary, ask in a forum about SQL Server. The SQL Server Security forum seems to be the best place.

Dear Mr. Martin.

Thanks for your links.

JFYI, SQL Server Management Studio in teh Database server wrorks fine.

But, I tried installing sql server management studio alone in the application server where I am plannign to install AX. In that Managment Studio…connection issue.


Dear Martin,

I vertiried the issue…the installed Sql server was not standard edition(Developer edition). I don’t think Ax supports this version.

Asked the client to get the sql server enterprise or standard editon.