BOM for item XXXXX has not been set up

Hi#### I’m using the Dynamics AX 2012 R2 system, it’s a pretty fresh system which i setup i few days ago.#### Step 1. Inventory and warehouse management → Bills of materials#### I created a BOM, BOM lines, Configuration route and Configuration rules, and i also add a relevant item for this BOM, both of them have been Approved and Activated.#### Step 2. Product information management → Released products.#### Since i have to configure the item configuration for the BOM relevant item, i select the item, on the action panel i go to “Engineer → Maintain configurations(Configuration Group)” which open the “Maintain configuration” dialog, but if i click the “Configure” menu item, i got the error “BOM for item XXXXX has not been set up”.####

the point is no matter i click “Engineer → Lines/Designer” i can see that the relevant BOM displayed.#### it’s really tricky and that makes me confused a couple of days.####

Hi

Please check whether BOM is active and approved?

I guess its not active due to this its showing error.

Regards,

Hi Mohammed,

i’m pretty sure that the BOM is approved and activated.

It seems like that Dynamics AX 2012 R2 is a little bit different from Dynamics AX 2012, in the dynamics ax 2012,

if i go to “Product information management → item(BOM relavant item)”, highlight the item and go to action panel “Engineer → Designer → BOM versions”.

in Dynamics AX 2012 , i have a menu on the form that i can select the BOM.

but in Dynamics AX 2012 R2, i don’t have the “select” menu on the form, and the relevant BOM is not selected.

In the BOM designer for the item, if i change the select criteria to “Active/Selected” then i have the “select” menu item and i can select the version now, but i still cannot “Maintain Configuration” for the item.

  1. Both BOM and relevant item is approved and activated now.

  2. Configuration Route and Rules are configured.

anything else that i should do? [:(]

I have encountered the same issue (identical) and have tried working this scenario in both AX 2012 R2 and R3. I get the same error message. Have you made any progress in resolving the problem?

Hi Cryer,

if i create the BOM first(before the item), i don’t know how to fix the problem.

but if i create the item first, then on action panel “Engineer->Design”. open the BOM designer for the item, then if you create the BOM from here, you won’t meet the problem.