Batch Status Stuck in Executing. Not resetting properly.

My Version:
AX5 2009
The problem:
Our batch services enter their execution state properly from their Waiting status as they should. They then finish correctly as I can tell when querying the table “Batch” they enter a status of 4 (Finished) here. When I then wait for them to reset and enter the Waiting status again it never occurs. They’ll just remain in status 2 (Executing) indefinitely on the “BatchRun” table. As I understand it the BatchRun.serverProcessFinishedJobs() method should be getting called every 60 seconds from the AOS. This method should take care of all the finished batch service cleanup and it seems like that’s not occurring. Note: This behavior is not present in our PRODUCTION environment.

What I’ve done thus far:
I wasn’t entirely sure if BatchRun.serverProcessFinishedJobs() was executing and returning because of an error/issue or if the method was not being called at all. What I did was manually overwrite this method with a call at the very top of the method to insert a log record in a testing table I created. After publishing this change in TEST and then restarting the AOSes I see the above behavior in which they move from Waiting to Executing and then they just stay there. I never see a log record being created, which gives me strong evidence to believe this method is not being called what-so-ever. I don’t have much direct visibility into how the AOS calls this method or even where to begin troubleshooting this from a low system level.


  1. Has anyone ever experienced anything like this before?

  2. Do you have a list of parameters, settings, or sanity checks that I could perform? Maybe there is a few I haven’t tried yet?

Hi shawn, I’m facing the same issue, have you resolved the problem? If so, can you tell me what are the checks you did ?
I have tried many checks but still stuck in the same point.