Axapta2009 and client logon

I get the message that my client cannot connect to the AOS.

How can this be… I har inserted the server and instance in config?

What’s the error message he receives?

If he get’s the message ‘Your user is not a recognized AX user’, you need to add his windows user to the AX user table.

Connection with the Application Object Server could not be established.

Connection to the Application Object Server could not be established.

As the message shows, the client cannot connect to AOS. To avoid such issues, store config files (.axc) in shared central repository.

How do I do that?

Where are the stored in the first place?

Is the service running?

Yes, and the client directly in the server i working okay.

Only I have the problem on another client (vista).

  1. In the Ax server (or wherever it is working), start Ax config utility. Click ‘Manage → Save configuration as file’.
  2. Save the file (.axc extension) in a shared directory.

Users can then either have copy of this directory or copy of actual file in their machine. Double clicking this file would trigger Ax. NOTE - you might have to associate this file with Ax client. This is one time setup.

Do you mean the configuration for the server og the client on my server machine?

To clarify, it is client configuration file which is saved using Ax client configuration utility.

Okay.

To change where the client config is looking for the config. file… where do I set up?

The client on the client now has exectly the same configuration as the client on the server.

Still I get the same error message…

What about the port 2712… is that important? Maybe for the router involved?

Port 2712 is the default TCP/IP port used by AOS. It looks your installation uses this default port.

How is the client connected to network? Also try following -

  1. Are you able to ping AOS server from client machine?
  2. Try running ‘netstat -a’ from client machine.

Port 2712 should be open on my router.

Yes I can ping the server … no problem.

Then it could be firewall which is blocking. You will have to work with your network administrator to resolve this.

Hi,

The problem is in start up of the service.

Go to Control Panel-> Administrative Tools → Services → MS Dynamics Ax 2009(or 4.0) → just click on stop / restart service

Hope this will help you.

If the service doesn’t get stated, Check up the AX client configuration utility properties…

The service does not exist on my client pc… is this the problem?

I only installed the client software on the client, should I have done more?

Hi,

To help you, i need to know hese things…

Did you install AX client on a standalone machine…? if so did you specify the server name while installing…?

if yes, did the installation succeed…?? if yes again… while opening AX, are you able to view the navigation pane…? content pane… ??

or… while opening itself it shows error stating the connetion to the AOS could not be established???

Hi TV1971,

Did you install ServicePack and Hotfix Rollups on the server?
If so, did you also do this for the client installation?

Are you able to open a telnet session on port 2712 to the server running the AOS Service?

And about the Client Configuration, i’ll provide you with the exact steps to verify: (Please do this at the client computer)

  1. Open Client Configuration Utility (Start → Run → AxCliCfg.exe)
  2. Target has to be “Local Client”
  3. Configuration should be the configuration you newly created.
  4. On the Tab Connection the follow settings should be correct:
    Server Name: Your AOS server
    Instance Name: The AOS Instance name (This can be found at the server configuration utilty on the AOS Server)
    TCP/IP Port: Port number the AOS is listening on (This can also be found in the Server Configuration Ultility on the server)
  5. If this is correct, save this file to Desktop (this is temporarly to see if the file is correct) by using Manage → Save Configuration file as
  6. Open the config file and see if it’s working.
  7. When it works, save this file a a shared directory as Harish said before.
  8. Start file from shared directory and see if it still works.

Good luck, if you have questions please let me know.