axapd.aoi troubles

Can someone explain to me the mechanics of the aoi file?

I’ve had issues over the past few month where this file gets totalled and has to be recreated by the system. Some times however it’ll be recreated and after a few minutes die again and need recreating once more like today I’ve done it 4 times in a row.

And it seemed to be tied to a particular user account, ie 50-70 users would be in fine this user would logon and immediately the aoi would start reindexing on this account kicking everyone out. Then I recreated it logged in with this user accout straightway and it again it tried to reindex, killed off the user session, and reindexed with my user account rather then the admin account and it reindexed fine and everyone could login again.

I logged this user in again thinking it would do it again and so there problem was with this user account but it worked and has continued to work fine. My VAR can’t give me any explanasion as to what would cause this behavoir or how to safe guard against it in the future.

So i am hoping some one here can give me more information.

Hi Diomedes

There are many reasons that can cause your problem…

If you could provide more information of your problems, I believe that we have help you on this. For example: your OS, your AX, DB and OS license, number of remote users, … All of that can cause your some failures on your .aoi files.

.AOI are Axapta Object Index files. You can refer to the Implementation Guide for for information…

I have 105 user Licenses, but I average about 85 active user sessions.

We’re using Axapta 3.0 sp 4 with MS SQL 2000 standard server running on a Windows 2003 Standard Edition server. The Ax application is also on this server on another volume.

It’s a 2 Tier arrangement and the clients range from Windows 2000 sp 4 to XP sp 2. Though there is 1 win98 machine in the plant that uses it from time to time.

Hi ,

I guess there are 2 reasons may cause your problem:

  1. Some user permission right problems with the OS. Such as some users don’t have read/write permission on the application folder.
  2. Your back up job on the application files. If you back up the application files when there are some “online” user, sometimes it will damage the aoi files.

Hope this helps.


What Khue is saying seems to make sense. Also please check whether the user in question is opening the application in exclusive mode.

Best wishes,