AX2012 (RTM) Reporting Extensions on SQL 2012 SP1 fails to install with File Not Found

Hi,

I’ve tried installing AX2012 (RTM) with hotfix (KB2680186) in order to support SQL Server 2012. There were some issues, all solved with this procedure: http://blogs.msdn.com/b/axsupport/archive/2012/06/26/unable-to-deploy-ax-2012-reporting-extensions-on-sql-server-2012-reporting-server.aspx

Now I am getting another error while installing Reporting Extensions (I’ve replaced usernames with some dummy ones):

2013-05-21 11:43:45Z An error occurred while adding users LOCALDOM\SRV_AX2012AOS_DEV,LOCALDOM\SRV_AX2012BC_DEV to the SQL Server Reporting Services DynamicsAXBrowser role in the folder DynamicsAX. The error is: Client found response content type of ‘text/html; charset=utf-8’, but expected ‘text/xml’.

2013-05-21 11:43:45Z The request failed with the error message:

2013-05-21 11:43:45Z –

2013-05-21 11:43:45Z

2013-05-21 11:43:45Z

2013-05-21 11:43:45Z

2013-05-21 11:43:45Z Error

Lots of HTML, and then “File not found” embedded in the HTML. It looks like the installer tries to a webservice (file) that does not exist on the reporting server…

The AX AOS is up and running and the AX WCF services are running. The system admin installed SQLServer 2012 SP1, but from what I’ve read AX 2012 (when patched) should be compatible.

Any ideas?

I tried installing on a plain SQL 2012 instead. It worked fine (with patches and several other required things installed).