AX2012 - missing data on forms

Hi all,

We do have AX2012 environment with demo data. Some master data (e.g. customers, vendors…) are suddently not visible on forms (existing in tables). For example setup of vendor groups or list of purchase orders is visible. Maybe it involves only some kinds of forms (from design point of view).

This happed us already on second environment and we do not know why.

Any ideas why it happend and what should we do to display these date on forms again?

Tomas

Hi,

Have you tried running consistency check tool (available under system admin > Periodic > Database).

No we have not. We will try.

thx

Is anyone trying to use definition groups for moving company data? This wrecks everything.

because of time preasure our admin is creating new environment instead. I cannot confirm if consistency check would help.

@Adam: No. We were not doing that.

EDIT: Finally I had chance to try the cons. check. Over all modules I got this error:

Numbers could not be generated because a number sequence reference is missing. Ensure that all necessary number sequences are set up.(C)\Classes\Info\add 13 (S)\Classes\Global\error 3 (S)\Classes\NumberSeq\newGetNum 13 (S)\Classes\LedgerPostingGeneralJournalController\new 3 (S)\Classes\LedgerPostingGeneralJournalController\construct 11 (S)\Classes\LedgerConsistencyCheck_Trans\run 17 (S)\Classes\SysConsistencyCheckJob\runClass 29 (S)\Classes\SysConsistencyCheckJob\runClass 25 (S)\Classes\SysConsistencyCheckJob\runClass 25 (S)\Classes\SysConsistencyCheckJob\run 14 (S)\Classes\SysConsistencyCheckJob\main 11

Over Customer module I got 78 errors regarding to Global adress book, and so on.

I still do not undestand why this happens, because its not for the first time…

A while back I tried using definition group route in AX 2012. It just doesn’t work and I believe it is a bug in AX.

Hi,

I received the same error at a customer site. If I run the following code, I get the above error.

info(strFmt(’%1’, NumberSeq::newGetNum(CustParameters::numRefCustAccount()).num()));

I looked into the code. Issue seems to be with NumberSequenceReference table not able to find the correct record. Has anyone else got this error and found a solution?

It is DAX 2012 CU2.

Harish i have same problem… do you have resolved this…??