AX2012 - Job Registration


I would like to use the job registration to start and feedback the job. However, i encounter a error when login to personnel number.

After i key in the personnel number, then i click login. The error message prompt:“is an invalid job ID”.

Please advise.




did you ever solve that problem? I am having the same problem.

I am playing around with the Manufacturing Execution System… unfortunately the new demo data in the latest R2 VPC does not match the training material.

Just at login, or are you logging onto a job? If you are then are you using job sceduling and how are the production parameters set in MES?

Hi, I solved in this way…

From the activity table delete and re-crete this record (System function=Stop Break).

This operation re-create the right jobid in JmgJobTable.

Best regards


Hi Vicenzo,

I am having the same error but I am not a programmer and was wondering if you could guide me in replicating your solution. I have checket all the settings in production control and HR modules without success.

Your help will be appreciated,


Hi Lee,

I am having the same issue and was wondering if you have found a solution.

Your time is appreciated,



I had a similar problem after creating a new company in AX 2009 and it turned out that I didn’t have any data in the JMGIPCACTIVITY table for that company. After running the Configuration wizard in Shop Floor Control > Setup > Wizards, my problem was cleared up. The configuration wizard populates the JMGIPCACTIVITY table with the default data.


Caro Vincenzo,

Could you say which is the activity table we should delete the record you mention? Also the picture you seem to attach is not showing in the post. It will be highly appreciated if you can through some more light on this issue. I promise to verify your solution if it works [:D]

Grazie mille e saluti,


Hello everybody, trying and looking around I make it work so far so good for now in AX 2012.

I made the following.

As per Jerry Wein recommendation I go and looked the JmgIpcActivity table, for the CEU (Contoso) company, there I found 6 records with Category=System among others.

In the company I was testing (CEED) there was nothing in that table, so I manually create those 6 system records as follows.

I needed to manually create the Category ‘System’ -the fourth column value- because it doesn’t existed also (Category=System, Description=System, Reg. type=Job) . After that, it started working.

Good luck!