AX2009 Ax32serv.exe crashes when creating customer invoice in server batch

Hello,

we have a problem when creating customer invoices in a server batch.

The aos crashes nearly every 3 minutes when printing the invoices to an .rtf file.

In the Windows Application Event Viewer we find the entry:

Application Error 1000

Fehlerhafte Anwendung Ax32Serv.exe, Version 5.0.1500.1313, Zeitstempel 0x4ab446b1, fehlerhaftes Modul GDI32.dll, Version 6.0.6002.18005, Zeitstempel 0x49e04114, Ausnahmecode 0xc00000fd, Fehleroffset 0x0000000000007354, Prozess-ID 0x%9, Anwendungsstartzeit %10.

Any ideas what the reason could be?

Hi,

Please can you translate the message in English? Also please provide Ax version details.

Thanks,

Hi,

my translation is:

error in Ax32Serv.exe, timestamp 0x4ab446b1, error in modul GDI32.dll, exit code 0xc00000fd, error offset 0x0000000000007354, process-ID 0x%9

Thank you

And the AX Version is:

AX2009 Version 5.0.1500.1313

Hi,

Per se this error doesn’t look coming from Dynamics Ax.

What printer / printer driver are you using? Can you try changing to another printer?

Regards,

Thank you.

we are printing to .rtf file.

But we will try this scenario: First only create invoices via server batch.

And, if the server doesn’t crash: Print invoices manually afterwards.

Hi Harish,

we have tried the scenario:

first: booking only - that worked fine

then: printing the invoices - that failed

Now we have tried different printerdrivers and we found out: some printerdrivers work fine and others don’t work

Hello Kikiko,

That is what I thought. Printer drivers are the culprit. I always recommend my customers to test Ax 2009 with all printer drivers in the organisation before go live.

Regards,

I am having the same problem. The AX service crashes while writing a file during batch processing only. Same AXversion too. I am confused on why this is a printer driver issue though because the server is writing ASCII (*.txt) file which should not be using a printer driver.

Faulting application Ax32Serv.exe, version 5.0.1500.1313, faulting module 4ab446b1, version Ax32Serv.exe, fault address 0x5.0.1500.1313.

To try to pretend it is a printer issue, I used Options to change it to various printers and then switched back to printing ASCII, but it always crashes on some AOS servers. I this case it is my virtualized servers that are having problems and the one non-virtual server works fine.