AX startup error

dear all,

i have a single AOS in my server and i can’t start the services. i’ve got error in system event viewer like that :

The Dynamics AX Object Server 5.0$02-AXDB02 service terminated with service-specific error 10 (0xA)

Anybody can’t help?



What is the error you see in Event viewer?

Most likely there may be issues to do with AOS service account. Check whether the settings are correct according to DAX 2009 installation guide.

This is the error in event viewer

The Dynamics AX Object Server 5.0$01-RSCMKeuangan service terminated with service-specific error 10 (0xA)

All the settings don’t change since it opened last time.

is there any problem maybe in computer setting or configuration?


Hi Posman,

Can you please check that the whether AOS Service Account has appropriate permissions in the database?

Hi Posman,

Make sure that :

  1. The AOS service Account is added to the database as a user, and is a member of the db_ddladmin, db_datareader, and db_datawriter database roles.

  2. The AOS service account has execute rights on the createserversessions and createusersessions stored procedures.

  3. The AOS service has Full Control permissions on the application files directory.

it’s already have a permission to connect SQL. is there any permission need to be granted?



You mention that none of the settings were changed since the last time it worked.

Perhaps is the AOS service account set to expire? Which account AOS has been configured to run with?


All settings have been done. but it still not working. is there any idea?


it’s administrator account.

i have checked in active directory, but the account set to never expired.

is there any related matter that can cause that error?


Is this problem still in need of a solution?

Verify if the Application Files path and database server and name of the AOS Instance are pointing to the correct values and make sure the rights are set as another poster said.