AX client restarts while AX full compile/ CIL in AX 2012 R2

Hi All,

  1. AX client restarts if i do Compile(all tables/Classes) in X++/ Full application compile or Full CIL.

  2. Also if i click on any form in System administration for e.g: Inbound port, checklists getting below error :

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

it has button Continue , quit

  1. I have enable Hot-swapping in AX server config because i got error : ‘CLRObject could not be created’

Please suggest

You probably have “Enable the hot-swapping of assemblies for each development session” enabled on the AX server configuration. Try turning it off.


thanks for the reply.

If i disable Hot-swapping im getting error : CLR Object could not be created

Try this

Some .dll files are missed or crashed at the C:\Program Files (x86)\Microsoft Dynamics AX\60\Client\Bin, Copy all the files from your working production environment and pasted into AX client system C:\Program Files (x86)\Microsoft Dynamics AX\60\Client\Bin.

I have copied Client bin folder from live environment to test and disabled hot-swapping , still same problem : client restart if i do compile/ CIL

Windows Log:

Faulting application name: Ax32.exe, version: 6.2.1000.1437, time stamp: 0x51c95f38
Faulting module name: RPCRT4.dll, version: 6.1.7601.23677, time stamp: 0x589c957a
Exception code: 0xc0000005
Fault offset: 0x0002c3cb
Faulting process id: 0x18f0
Faulting application start time: 0x01d4c242aa10b644
Faulting application path: C:\Program Files (x86)\Microsoft Dynamics AX\60\Client\Bin\Ax32.exe
Faulting module path: C:\Windows\syswow64\RPCRT4.dll
Report Id: 210711b0-2e37-11e9-b298-00155d16cc05

Please go ahead and delete auc and kti files in your users local appdata folder. The AX client needs to be closed during the deletion of those files.

And try again your process

I have deleted the files, still getting the same error.

Let me explain what exactly i have done:

There is test environment which already working fine where AOS, SQL are in same server. Due to performance issue we moved the SQL to different server and we have uninstalled the AX in existing machine and re-installed in the same machine pointing the database to the different server where the SQL installed newly.

Also restored latest Live database in newly SQL test server.

After installing getting CLR object could not be created while opening AX, also if i try to open any form also getting same error, still i continue to put full application compilation & Full CIL - both operation stopping the AOS service. Then i have enabled Hot-Swapping in AX server configuration after CLR error not came and tried to put full application Compilation/ Full CIL both the case client crashes and closed.

I have tried copying Client BIN from live to test still same error, also tried copying server BIN folder and deleted .AUC and KTI files for all the users.

All the above are tried in admin login

Did you tried Clearing XPPL files??
is Application version and Kernal versions are the same

And also disable just in time debugging through registry it may also the major reason for AX crash

I have stopped AOS and deleted the XPPL folder and started again then tried FULL CIL but same issue.

how to disable Just in time debugging through registry?

Try this link