AX 2012 Function DimensionStorage.addHierarchy has been incorrectly called

Hi All,

Has any one experience this issue “Function DimensionStorage.addHierarchy has been incorrectly called”

whenever i click on any account or create any journal i m getting this error.

please suggest a solution.

Thanks in advance.

\Classes\DimensionStorage\addHierarchy verifies many conditions for generating this error. try to debug and see which condition is actually causing error in your case.

Hi Kranthi,

Thanks for your response and this issue is fixed.

But i have another one I opened the voucher transaction form (General Ledger-> Inquires->voucher transaction) after the query dialog i see the records and if i selected one record & clicked Transaction Origin button and in that form i m not seeing any values (dim combination) in Financial dimension tab.

have you experienced this issue before.

Thanks.

Can you explain how the issue was fixed? I am getting the same error only for one specific ledger account when creating a free text invoice.

Hi, I am getting this error while selecting offset account in the journal lines and if i tried to select for the second time the error gets disappeared. do you have a fix for this ?