AX 2012: AR Customer Statement report returns an error

When running Customer statement for report in AR >Customers >All customers >Collect tab >Statements get the following error: parameter ‘CustAccount’ does not exist on this report. We have several legal entities and this report works only under one of them. Any ideas what might be causing this?

The error is triggered here: \Classes\SRSProxy\handleClrException line 18.

Call stack:

  • \Classes\SRSProxy\handleClrException 18
  • \Forms\SrsReportViewer\Methods\run 47
  • \Classes\SysSetupFormRun\run 9
  • \Classes\Dialog\doRun 26
  • \Classes\SysOperationDialog\run 12
  • \Classes\SrsPrintMgmtController\dialogShow 17
  • \Classes\SysOperationController\dialogRun 40
  • \Classes\SysOperationController\prompt 9
  • \Classes\SrsReportRunController\runToScreen 26
  • \Classes\SrsPrintMgmtController\runReport 46
  • \Classes\PrintMgmtReportRun\execute 41
  • \Classes\FormLetterReport\execute 10
  • \Classes\SrsPrintMgmtFormLetterController\outputReport 17
  • \Classes\GiroPrintMgmtFormLetterController\outputReport 44
  • \Classes\CustAccountStatementExtController\outputReport 17
  • \Classes\SrsPrintMgmtFormLetterController\runOutputReports 26
  • \Classes\GiroPrintMgmtFormLetterController\runOutputReports 22
  • \Classes\SrsPrintMgmtController\outputReports 80
  • \Classes\CustAccountStatementExtController\runPrintMgmt 116
  • \Classes\SrsPrintMgmtController\run 14
  • \Classes\SysOperationController\startOperation 10
  • \Classes\SrsReportRunController\startOperation 12
  • \Classes\SrsPrintMgmtController\startOperation 14
  • \Classes\SrsPrintMgmtFormLetterController\startOperation 14
  • \Classes\CustAccountStatementExtController\main 7
  • \Classes\FormFunctionButtonControl\Clicked 0