Attain client cannot connect to server

Hi I have a problem connecting 2 clients, a 3.01 and a 3.10 to a server. When I enter the server name in the Open Database dialog box and press enter, I get the message “The server and client do not have the same program version number”. The servers are running on a supportserver with several other servers. I can connect to other servers of the same version without any problems, and I can also start a client on the server itself and connect to the “problem” servers. My services- and hosts-files are correct. I’m using the parameter ID= I’ve tried to delete the .zup - files The server is Win2000 Advanced Server, my workstation is Win2000. Any ideas? I’ve so far not gotten any response from Navision’s supportdesk. Regards Tommy



… 2 clients, a 3.01 and a 3.10 …

So which version is the server? Is it really possible to connect clients with different versions to server 3.01 or 3.10? I allways thought, server and clients have to have the same version!? Regards, Jörg

Maybe I should clarify this - I’m not trying to connect different versions - but I have the same problem on 2 different versions of Attain. Tommy

Hi Tommy, If I understand your original post correctly, you’ve got two versions of the Server service on your Server, one 3.10 service, one 3.01 service. I don’t want to sound patronizing or anything, but have you installed each service with it’s own port, as described in the documentation that comes with the install? This is what the problem sounds like to me. Additionally, you need to make sure all your naming protocols add up to look to the correct port as well. The easiest way I found to check this is to bypass the naming and go straight to the IP address, including your port information in the Open Database dialog. For example, I’ve two services on my server with IP: “Service one” is using the standard port, so no issue. “Service two” is using port 3000. To access it, I’d just type “” to access “Service two”.

Hi Kristopher Thank you for your answer. Yes, I have different portnumbers for the different servers (I have 15 3.01 and 3.10 server-services running on the same server - works fine). And I don’t find your answer patronizing - I’ve seen so many skilled Navision proffessionals try to install 2 servers without the port numbers. Before I received your answer, I was checking the version numbers of the server.exe and the fin.exe files to see if there was a version conflict. There wasn’t, but when I was looking at the fin.exe file in an explorer, I tried starting the 3.01 client by double-clicking it directly - and suddenly it worked - and my shortcut worked as well after that. I tried the same with the 3.10 client, but that didn’t work. But your tip about accessing the service with IP-address:port-number worked. I still would like to know why typing the servername in the open database dialog doesn’t work, but at least now I know how to work around it. Thanks a lot. Tommy