'Another user modified the record....'

I have a problem where I have a vendor with an invoice and payment that I want to apply to each other. I go into Vendor Ledger Entries->Apply Items and follow the correct procedure to match the 2 transactions together, but after clicking ‘Post Application’ and accepting the posting date, I get the error ‘Another user modified the record after you retrieved it from the database …’ This happens even if I’m the only person using the system. Any ideas how to solve this? I’m using Navision 3.70 SQL Server option with SQL 2000 SP3. Thanks, Jonathan

My guess is that a CurrForm.UPDATE function is being called in an incorrect place.

The Application of Posted Ledger Entries is a standard functionality. For you to get this error message, someone had to modify the standard behaviour (probably your MBS-Partner). Now is a good time to call them. [:)]

My firm is an MBS Partner, I work in the IT department and am posting on behalf of our accountant - we use Navision internally. I know that the only changes we have made to the standard 3.70 installation are the BACS Export report and the cheque/remittance advice. Is there some tinkering we should have done post installation? Any other ideas? Jonathan

That’s odd, I just tested the Application of a Posted Invoice and a Posted Payment in 3.70 and didn’t get any error messages. It is possible that you uncovered a bug, but I find it hard to believe. That’s why I asked about changes. Perhaps someone in this forum has been up against the same scenario in a standard database and can give you a better answer.

Hi Jonathan As an NSC you should have access to Cronus on a different database. Process a payment against a vendor (I think it will have to be a foreign currency vendor as the message you are receiving regarding the posting date indicates this). Then set the applies to ID on the invoice and payment and post the application. It works fine for me [:D]

Many thanks for the input guys. I’ve now tried this on a different SQL server using Chronus data - input a simple invoice and payment and tried to apply and get the same error! Jonathan

Hi Jonathan No offence but it must be you [:D] Tell us step by step what you are doing!

quote:


Originally posted by Jonathan2708
Many thanks for the input guys. I’ve now tried this on a different SQL server using Chronus data - input a simple invoice and payment and tried to apply and get the same error! Jonathan


Not just Cronus data, but the whole Cronus unmodified database. Try it in native database first and see if you get the message, if not, then restore the native database to SQL with objects and all.

Hey guys, we had the same problem and it gave us some hard time. finally, the only solution we came across was to switch off the Tolerance Flag in the Vendor master table. This solved the problem and finance can now post without this error occuring again. Hope this helps[:D]

quote:


Originally posted by apickard
Hey guys, the Tolerance Flag in the Vendor master table. Hope this helps[:D]


Just for clarity’s sake - I mean “Block Payment Tolerance” field on the Payment’s tab on the Vendor Card. Hope this is more understandable [;)]

Many thanks Angelo you’re a star. Jonathan

We’ve also noticed this kind of behaviour. In Native this works ok. It’s SQL that acts a littlebit different sometimes.

We had same problem … solved with Hotfix 6 in W1. Regards, Matthias.

We had same problem … solved with Hotfix 6 in W1. Regards, Matthias.

The problem is in codeunit 426 and as involves ledger entries the solution centre will need to correct this.