Action (Bolt) don't work when Page is Sub Part

Microsoft Dynamics NAV 2009 RTC

I have a strane issue. I create a new Action (DoStuff) on a list page. When I open the page directly, I can click on the small lightning bolt and it pops out the menu and I can run my Action.

However, as soon as I am running the same page as a page part on another page, I can not click the bolt icon. The icon is visible, but nothing happens when I am clicking.

On other page parts I have created this works. Only on this page it won’t.

Can you show a screenshot?

Can you simply add Message(‘Hit’); under the action and try

Well, the problem is, that I can not provide you a screenshot, because there is nothing to see. A click on the bolt icon and nothing happens. Not that the action is hidden, the whole menu does not pop up. It just happens nothing, besides a tiny page flickering.

When I add another list part I created on the same page, the actions work as expected.

If I run the list part by itself (per Run->dynamicsnav://…) I can click the bolt icon and then the actions shows and then I can click the action and the action gets executed as expected.

Ok here are the requested screenshots:

This is the screen after I clicked the bolt:

This is the screen after I clicked the bolt on another page part:

And this is (the left) page when I run it with dynamicsnav://…

Thank you… Its clear now.

Did you try by adding a simple message under action?

The code for both actions Test and newOrder are


I found the error.

The Page , which was included as as sub page was declared as type List. The problems seems to be, that if a sub page is declared as List and not as ListPart, the action button (lightning bolt) does not work and every thing seems to be buggy.

This also happens when a sub is not declared as PagePart but instead as Page.

So, ich changed the declaration to ListPart and now everything works.