Access Denied

Today morning i witness a strange issue while login to NAV Client.

I entered the server IP, Username, Password and i selected the DB which i am going to login, and then pressed OK button, immediately error message “Access Denied” appeared in the screen.

But, i can login to SQL DB through SQL Management Studio with the same NAV username and password. Did anyone come across with this issue? I am clueless what is wrong with the NAV client.

Please help me to resolve the issue


any idea pls?

What version of NAV? Is the user setup with permissions inside of NAV? Depending on version and if the user is assigned permissions, try syncing that user permissions.

Try to synchronize the logins…


We have resolved the issue. Thank you for all your support.

below the steps what i have tried to solve this issue…

  1. Initially tried through resigning the user role permissions in SQL ---- Unable to solve through this method.
  2. Deleted user and created the user once again with DB owner and with Sys administrator permission ---- Failed.
  3. Finally Taken all DB’s to offline mode and deleted SQL master DB Extened permissions, properties and then restored the same once again. Then made all DB’s to online mode— Problem solved.

Kindly give another idea because these havent worked for me

Although I must admiit that my temporary solution has been to use the Web client i.e(I can properly access the same company with a user who is using NAVUSER password Authentication in the webclient)

Hi Frank,
In general a bad idea to reply to a 4 year old thread…
Better to start a new question, and put a link to the old “similar” question.

In this situation the reasons can be many, depending on the version.
And what are you using Windows or NAV users or?

Thanks, let me post my exact situation as a new question

NAV user